2010/06/25

今月のWindows UpdateでVista/XP/Server 2003/Server 2008用のWindows PowerShell 2.0が提供開始になりました。Windows Server 2008の場合では次のような表示になります。

Windows Server 2008 用の Windows PowerShell 2.0 および WinRM 2.0 (KB968930)

ダウンロード サイズ: 32.4 MB

この更新プログラムを有効にするには、コンピューターを再起動する必要があります。

更新プログラムの種類: オプション

Windows 管理フレームワーク コア パッケージには、Windows PowerShell 2.0 および Windows リモート管理 (WinRM) 2.0 が含まれています。Windows 管理フレームワークの詳細については、http://support.microsoft.com/kb/968929 を参照してください。

詳細情報:
http://go.microsoft.com/fwlink/?LinkID=165613

 

公式ブログの記事:Windows PowerShell 2.0 on Windows Update - Windows PowerShell Blog - Site Home - MSDN Blogs

このアップデートは強制ではなくオプションです。このアップデートを適用すると、Windows 管理フレームワーク (Windows PowerShell 2. 0、WinRM 2. 0、および BITS 4. 0) をインストーラーを使用して適用するのと同様にPowerShell 2.0を導入することができます。なお、このインストーラーではPowerShell 1.0があらかじめシステムにインストールされている場合は前もってアンインストールする必要がありましたが、Windows Updateの場合はアンインストールの必要はなく、自動的に1.0が上書きされ2.0になります。なお.NET Framework 2.0 sp1以上がインストールされていない場合、または、正式版でないPowerShellがシステムにインストールされている場合、このアップデートは候補に現れません。

このアップデートはアンインストールすることができます。その場合はコントロールパネルの「プログラムと機能」などで「更新プログラム」を表示し、「Windows Management Framework Core」を選択します。なおこのアップデートをする前にv1.0をインストールしていた場合は、当該アップデートをアンインストールすることでPowerShellのバージョンがv2.0からv1.0に戻ります。

元記事:http://blogs.wankuma.com/mutaguchi/archive/2010/06/25/190599.aspx

2009/10/28

PowerShell 2.0のXP/Vista/2003/2008用の正式版が10/26にリリースされました。

Description of the Windows Management Framework on Windows XP, Windows Server 2003, Windows Vista, and Windows Server 2008
http://support.microsoft.com/kb/968929/en-us

結局、日本語版のインストーラーがどこにあるのか分かりにくいので直リンクをどうぞ。

2008 x86
2008 x64
2003 x86
2003 x64
Vista x86
Vista x64
XP

パッケージに関して、くわしくはこちらの記事を。

Windows PowerShell Blog : Windows Management Framework is here!
http://blogs.msdn.com/powershell/archive/2009/10/27/windows-management-framework-is-here.aspx

Shigeya Tanabe's blog : XP, Vista, Windows Server 2003, 2008 向けの Windows Powershell 2.0 が公開されました
http://blogs.technet.com/stanabe/archive/2009/10/28/powershell-for-xp-vista-ws03-ws08-released.aspx

さて、PowerShell 2.0は1.0と同居できないため、1.0がインストールされている環境だとインストーラーではねられます。まずは1.0をアンインストールしてください。2008では機能の削除、2003などではプログラムの追加と削除から、「更新プログラム」チェックをつけて「kb926140」を削除してください。

元記事:http://blogs.wankuma.com/mutaguchi/archive/2009/10/28/182502.aspx

2006/11/15

Windows Server 2003 Service Pack 1 および Windows XP Service Pack 2 用の Windows PowerShell 1.0 ローカライズ版インストール パッケージ
http://support.microsoft.com/kb/926140

出ました〜。

RC2をインストールしている方は、コンパネの「プログラムの追加と削除」から「更新プログラムの表示」にチェックを入れてアンインストールしてください。

RC2ベースのユーザーガイドが日本語化されてますな。RC1のユーザーガイドは無かったものとされたらしいです。もってる方は大切に保管しておきましょう。RC2はシェルよりの解説、RC1はスクリプトよりの解説がされています。

Vista用はどこ〜?

P.S.
IE7を入れるとWSHが5.6から5.7になるらしいです。これも検証しなくては。

元記事:http://blogs.wankuma.com/mutaguchi/archive/2006/11/15/45481.aspx


Copyright © 2005-2018 Daisuke Mutaguchi All rights reserved
mailto: mutaguchi at roy.hi-ho.ne.jp
プライバシーポリシー

Twitter

Books